Club Subaru Todocamino

El club de usuarios de los Subaru más offroad.

Monitorización DPF (filtro de partículas) con ELM327 y Torque (Turorial)

Objetivo

Conocer el estado del filtro de partículas (DPF) de los modelos con motor diesel:

  • Saturación del filtro de partículas en % (soot)
  • Estimación de porcentaje de combustible disuelto en el aceite del motor
  • Número de regeneraciones activas realizadas en la vida del coche
  • Estado actual de la regeneración: si hay una regeneración activa o no.

Antecedentes

Todos los motores diesel actuales incluyen un DPF para evitar que salgan a la atmósfera partículas contaminantes y que dichos motores cumplan los niveles de emisiones legales. El DPF captura estas partículas, las quema en su interior y las expulsa como residuos que ya no son nocivos (o no lo son tanto). Este proceso es la regeneración del filtro y ocurre de varias formas:

  • Regeneración térmica: ocurre con el vehículo funcionando con carga elevada: remolcando, subidas prolongadas, etc. La temperatura en el DPF aumenta lo suficiente para producir la combustión de las partículas.
  • Regeneración pasiva: ocurre con el vehículo caliente, con carga normal: circulando por carretera, etc. Las partículas se descomponen químicamente.
  • Regeneración activa: cuando la saturación del filtro está entre el 65% y 75%, el sistema de inyección del vehículo hace llegar gasoil al DPF para aumentar su temperatura y producir el proceso de combustión de las partículas. Si la saturación llega al 85% se enciende un piloto luminoso indicando al conductor que debe conducir de forma continua para que se complete el proceso de regeneración.
  • Regeneración forzada: cuando la saturación llega al 100% hay que ir a un taller para que activen una regeneración forzada.

Este proceso hace que los diesel actuales presenten problemas con la regeneración del DPF en vehículos que se usan sólo para trayectos cortos y sobre todo en ciudad. De ahí el interés de conocer en qué estado está el DPF y cómo se realiza el proceso de regeneración.

Se incluye documento técnico de Subaru Australia sobre el tema.

Materiales

  • Adaptador OBD-II bluetooth. ELM327 o similar (amazon.es, dx.com, ...)
  • Dispositivo Android con bluetooth.
  • Aplicación Torque Pro para Android: la versión Pro es de pago, la versión gratuita no me ha funcionado. Con algunos adaptadores OBD-II viene la versión Pro (ya pagada?) en un archivo APK. También es fácil localizar el APK de la versión Pro en redes P2P.
  • Vehículo Subaru Diesel. Probado en Forester 2.0D MT 2013.

Configuración

Instalamos el adaptador OBD-II en el conector del bus CAN del coche. El conector suele encontrarse bajo el volante, cerca de la zona de fusibles.


Sincronizamos el dispositivo OBD-II con el dispositivo Android. Las instrucciones deben venir con el dispositivo, pero normalmente basta con activar el bluttooth en Android, buscar dipositivos BT y añadir el OBD-II. La clave para vincularlo debe ser 1234, 0000 o algo parecido.

Instalamos Torque Pro en el dispositivo Android. Comprobamos que Torque se conecta con el coche. Para ello tenemos que tener el coche arrancado o al menos con el contacto dado. Podemos añadir visores a las pantallas de torque para la temperatura, velocidad, etc.

Torque nos permite monitorizar muchos parámetros estándar del protocolo OBD-II, pero los parámetros del DPF tienen identificadores (PID) propios de Subaru y hay que configurar Torque. El proceso de configuración de PID's en Torque Pro es como sigue:

Entramos en la configuración general -> Gestionar PIDs/Sensores Extra -> Añadir PID personalizado.

Aquí tenemos que indicar el número del PID (en hexadecimal), un nombre largo, un nombre corto y la ecuación para calcular el parámetro. En la siguiente tabla están los datos para los PIDs que tenemos que añadir. Los nombres se pueden elegir a voluntad.


Nombre

N. corto

PID

min.

máx.

Equation

DPG reg. count

DPF count

221157

0

65535

A*256+B

Soot %

Soot %.

22114D

0

255

A

DPF reg. on/off

DPF on/off

22125B

0

255

A

Oil dilution ratio

Oil dil.%

22114E

0

100

A

Una vez que tenemos estos PIDs configurados en Torque, los podemos añadir a las pantallas como cualquier otro indicador. Basta pulsar sobre el fondo de la pantalla y añadir el elemento con el tipo de visor que más nos guste. Para el estado de la regeneración del DPF (DPF on/off) es conveniente usar el visor tipo pantalla apagado/encendido. En la imagen podéis ver mi configuración con las temperaturas y carga del motor el la parte de arriba y los parámetros del DPF en la parte de abajo.


Pruebas

Con estos datos he estado observando como subía el nivel de saturación del filtro: un 5% diario aproximadamente en 4 trayectos al día (unos 60km en total). El porcentaje de gasoil en aceite era del 2% hace unos días bajando posteriormente al 1%. El leído que el valor es estimado: sube con las regeneraciones y baja con el tiempo, ya que se estima que el gasoil en aceite se evapora con el tiempo.

Hoy, al llegar al 65% de saturación se ha iniciado una regeneración activa. La secuencia de imágenes está más abajo. Las observaciones son:

  • La regeneración ha comenzado con el motor relativamente frio y andando con suavidad.

  • Durante la regeneración he hecho mi trayecto habitual: conducción suave, 80km/h, en torno a 2000rpm.

  • La regeneración ha durado 12 minutos, lo que coincide con el documento del DPF de Subaru donde dice que la regeneración para cuando la saturación baja del 30% pero dura al menos 12 minutos. En mi caso, en los 12 minutos, la saturación ha bajado al 0% (a los 11 minutos aproximadamente) y el gasoil en aceite a subido del 1% al 2%.

  • La media de regeneraciones en mi caso sale a una regeneración cada 1000km.

  • El consumo en el trayecto ha aumentado aproximadamente en 1l/100km respecto del cosumo que suelo hacer.

Conclusiones

Esta herramienta me parece muy interesante para aquellos que sospechen que su coche hace muchas regeneraciones o que ven un consumo elevado que pueda deberse a las mismas.

Espero que os sirva de ayuda.

Capturas

Se inicia la regeneración al 65% de saturación, unos minutos después arrancar el coche.

En pocos minutos la saturación baja rápidamente.

Sigue bajando...

A los 10min. es prácticamente cero.

A los 12min. la saturación ha bajado a cero, se desconecta la regeneración activa y la cuenta de regeneraciones aumenta en uno.

Visitas: 19526

Archivos adjuntos

Responde a esto

Respuestas a esta discusión


como ya te ha comentado Mr Jones, es pq usas un dispositivo inalambrico que interfiere en las señales que envia la ECU a los distintos dispositivos del coche en alta velocidad....

arranca y luego conectas el ELM o slimilar y no tendras problemas.


Andrés dijo:

Buenas.

Este pasado viernes conecté el OBD-II y circulando vi que el indicador DPF llegó al 65% y se puso en ON la regeneración filtro. Estuve circulando en modo manual y por encima de las 2.000 revoluciones hasta ver que bajó a 0% y los indicadores  "DPF reg att" que estaba en 5 subió a 6 y el indicador "DPF count" que estaba en 2 subió a 3. Hasta ahí bien...

El indicador "Oil dil" que estaba en el 3% subió al 4%... que porcentaje de gasoil en el aceite del motor puede suponer un problema?.

La cuestión que en principio hasta ahí todo bien. Luego al poco de haberse producido esa regeneración apagué el motor y al poco que volví a hacer uso del coche, al poco de empezar a circular se me pone en modo fallo y se me enciende varios testigos de fallo motor: el de "chequin" (o como se escriba).... el de control de velocidad, el indicador de pendiente y alguno más...  y parece venía un cierto olor fuerte del motor... dándome la sensación de que el motor no tiraba y no pasaba de las 2.000 revoluciones.

Inmediantamente pasé por el concesionario y les dejé el coche. Cuando lo recogí me informaron que el problema que se me encendiera el testigo fallo motro más los otros es que fue por una acumulación de gases y ya me resetearon los fallos y me hicieron una regeneración..   y que cuando se me encienda fija la luz en el salpicadero el testigo de obsturación DPF lo lleve para que me haga una regeración del filtro, aunque ayer no fue el caso, ya que no se me había encendido dicho aviso en el salpicadero y de hecho fue el OBD-II que conecté el que me avisó y le fui haciendo en marcha circulando con el vehículo la regeneración del filtro hasta que llegó al 0% y saltaron los contadores indicados anteriormente.

No entiendo lo que me ocurrió posteriormente que se me encendiera el testigo de fallo motor y los demás indicadores en el salpicadero y lo que me dijo que fuera por una acumulación de gases...

Si alguien sabe decirme algo sobre lo sucedido y evitar en lo posible me vuelva a ocurrir..

Saludos.

Adjunto imágenes de capturas de pantalla del Torque antes y después de la última regeneración que me hizo el viernes y antes de que luego se me pusiera en fallo motor.

.

Gracias Mr. Jones y Pelayo por las aclaraciones... Saludos.

A mí me pasó, porque lo llevaba puesto y paré a repostar sin apagarlo. Desde entonces sigo el protocolo que dice Pelayo y sin problemas. Por cierto, se apagó solo al rato y hasta la fecha, supongo que se quedaría grabado el error, ya me dirán en la proxima revisión. Pero dudo que tu coche necesitara otra regeneración...

Hola a todos!!

Pedazo de post!! Enhorabuena porque es muy útil la información que habéis puesto aquí. De hecho tenía puesto un anuncio para vender el coche y cambiarlo por el de gasolina, pero viendo esto y que no me dan lo que pido, prefiero quedármelo ya que el coche me encanta, con la salvedad del maldito FAP. 

Con todo esto que he leído he comprado el ELM327 y en cuanto lo reciba quiero configurarlo igual que Blady ya que mi coche es del 02/2015 y creo que monta el mismo motor (corregidme si me equivoco).

De todas formas gracias a ti Blady por iniciar este hilo tan útil y por la aportación de todos. Saludos!! 

Blopas: me alegro de que te sea útil. Mi modelo es de 2013. Creo que para 2015 hubo algunos cambios estéticos menores y mejoras mecánicas, pero no sé si afectaron sólo al modelo Lineartronic o también al manual.

Ya nos contarás tus experiencias.

Bueno pues tengo configurado ya el Torque pro y pretendo conectarlo al coche en cuanto llegue a casa, pero me han surgido algunas preguntas a la hora de hacerlo, a ver si me las podéis resolver:

Al configurar los PID, he introducido los datos tal como los ha puesto Blady, pero he visto que hay más campos que los he dejado en blanco, ¿es correcto?

Por otro lado hay PID que no se para que sirven:

-22124F Glow relay switch

-22003E Exhaust Gas Temperature (EGT) at DPF inlet

Ya os contaré si me ha funcionado.

Es correcto. Nunca he modificado esos campos. Supongo que son útiles para casos especiales.

Blopas dijo:

Bueno pues tengo configurado ya el Torque pro y pretendo conectarlo al coche en cuanto llegue a casa, pero me han surgido algunas preguntas a la hora de hacerlo, a ver si me las podéis resolver:

Al configurar los PID, he introducido los datos tal como los ha puesto Blady, pero he visto que hay más campos que los he dejado en blanco, ¿es correcto?

Por otro lado hay PID que no se para que sirven:

-22124F Glow relay switch

-22003E Exhaust Gas Temperature (EGT) at DPF inlet

Ya os contaré si me ha funcionado.

Buenas a todos de nuevo, 

Después de dos días circulando con el coche, me temo que no me funcionan algunos de los PID configurados, sobre todo me he fijado en el de la saturación del FAP, que tengo configurado de la siguiente manera:

Cuando iba circulando ayer, me registraba estos datos:

Creo que es imposible que desde que lo conecté no haya subido ni un 1% la saturación. No se si es un problema de la configuración justo de ese PID, puesto que se pueden ver en la pantalla otros PID que si que funcionan (a excepción de los dos relojes de arriba que son propios de Torque). 

Otra cosa que estoy pensando es que tenga un problema con el Fimware del ELM327, como le pasó a Torkem Fores (os indico más abajo su comentario)

Esto me extraña puesto que mi coche es de 02/2015 y por lo que he comprobado en la ficha técnica lleva motor EURO5.

A ver si me podéis echar un cable..

Torkem_Fores dijo:

Buenos días,

 

Primero de todo, Blady, por fin me funciona ALELUYA!!

Es largo de explicar pero resumiendo contacte con un compañero de foro de Torque (por cierto me hacía gracia porque el colega era ruso y los volcados de pantalla que me enviaba de su configuración estaba en ruso jejeje, ni papa…). El caso es que al final era problema de la versión del Firware. Era incorrecta. Compre otro ODBII, aproveche para que fuera on/off, y así lo dejo puesto. Todo ok.

El PID de intentos de regeneración ya lo había visto porque he estado una temporada mirando constantemente el foro de subdiesel para poder solucionar mi problema. Cuando lo ví pensé: tengo que comentarlo a los chic@s. Al final cuando ya lo conseguí, había pasados semanas (por no decir meses) y se me paso… sorry!!

Por cierto, te cobran 13€ por decir el valor de un PID…¿?¿?¿?

Si yo cuando voy por mis “olores” (parece ya mi segunda casa) les digo: como tengo esto, y muy amablemente me lo comprueban a cambio de un simple muchas gracias… 

Cudillera, me parece que no estamos hablando de la misma aplicación.

Mírate esta url: https://torque-bhp.com/  y la comparas.

Sino es la misma, nosotros, al menos yo, no te podremos ayudar por desconocimiento de la app.

un saludo,

 

Bueno Blady, 

Perdóname porque me he saltado por alto cosas que has colgado por aquí. Acabo de meter toda tu configuración, voy a probarlo y te digo.

También vi un comentario que le pusiste a Andrés con lo que significa cada PID que has puesto.

Una vez más gracias!!

Hola Blopas.. Yo también me hice con el adaptador OBDII que había por aquí puesto e instalé los PIDs que me indicó Blady.
Mi Forester es de marzo de 2017 (euro6) y en principio si creo que me funcionan correctamente esos PIDS.
Lo que hice es decargarmelos del enlace que había puesto en este post y sustituirlos en la carpeta según indicaban como hacerlo.
No lo llevo permanentemente conectado y sólo lo hago de tarde en tarde para ver la información de las regeneraciones.
Ahora he venido de unos días de vacaciones y le hice unos 1.200 km al coche pero, se me olvidó echarme el ELM327 y no lo puede conectar para que me fuera informando del filtro y demás.. A ver si un día de estos lo conecto y veo los cambios que han habido desde la última vez que lo conecté.
Saludos.

Sigo comentando impresiones para que sirvan de registro...

Como dice Andrés, yo lo conecto de cuando en cuando solamente, y seguro que me pierdo varias cosas. Pero me llamó la atención que en una de esas "tardes" coincidió que a los 10 minutos empezó a regenerar... ya es casualidad. Pero lo hizo en una bajada en la que poco puedo acelerar que hay de Úbeda a Jódar, y a los 5 minutos dejó de hacerlo, aunque no contó como interrumpida. Simplemente la aplazó hasta que el terreno volvió a ser horizontal y ahí si la hizo sin mayor novedad. Lo que sí me sorprendió, es que esta regeneración llegó a los 500 km escasos de la anterior, cuando las que constaté desde que compré el ODb pasaban todas ampliamente de los 1000 kms. Estaré pendiente. No se si influirá que esa se hizo justo antes de la revisión de los 15.000 kms.

Por cierto, en dicha revisión no me dijeron nada de que se me hubiese encendido una vez en el cuadro las luces que se comentan más arriba, como si no se hubiese quedado grabado en error. También me comentaron que la diagnosis del FAP estaba correcta. Cuando les dije que solo uso el coche en carretera y en tiradas de más de 100 km, me respondieron que no tendré problemas de filtro. Espero que así sea...

Seguiré informando... quiero conectarlo ahora recién pasada la revisión a ver si noto algo nuevo,

Por cierto, a los expertos: Nadie ha conseguido conectar el Actibe OBD para ver el par en cada eje al Torque?

Correcto. A mí me pasa continuamente: la regeneración no se completa y se interrumpe antes de los 12 minutos de rigor normalmente bastando unos 20 segundos de conducción en freno motor.

Dado que antes de mi casa hay una cuesta abajo larga y apenas hago trayectos deveinte minutos, llevo desde semana santa sin una regeneración completa de doce minutos 



el-zahori dijo:

Sigo comentando impresiones para que sirvan de registro...

Como dice Andrés, yo lo conecto de cuando en cuando solamente, y seguro que me pierdo varias cosas. Pero me llamó la atención que en una de esas "tardes" coincidió que a los 10 minutos empezó a regenerar... ya es casualidad. Pero lo hizo en una bajada en la que poco puedo acelerar que hay de Úbeda a Jódar, y a los 5 minutos dejó de hacerlo, aunque no contó como interrumpida. Simplemente la aplazó hasta que el terreno volvió a ser horizontal y ahí si la hizo sin mayor novedad. Lo que sí me sorprendió, es que esta regeneración llegó a los 500 km escasos de la anterior, cuando las que constaté desde que compré el ODb pasaban todas ampliamente de los 1000 kms. Estaré pendiente. No se si influirá que esa se hizo justo antes de la revisión de los 15.000 kms.

Por cierto, en dicha revisión no me dijeron nada de que se me hubiese encendido una vez en el cuadro las luces que se comentan más arriba, como si no se hubiese quedado grabado en error. También me comentaron que la diagnosis del FAP estaba correcta. Cuando les dije que solo uso el coche en carretera y en tiradas de más de 100 km, me respondieron que no tendré problemas de filtro. Espero que así sea...

Seguiré informando... quiero conectarlo ahora recién pasada la revisión a ver si noto algo nuevo,

Por cierto, a los expertos: Nadie ha conseguido conectar el Actibe OBD para ver el par en cada eje al Torque?

Responder a debate

RSS

Buscador

¿Necesitas mas información?

Foros Amigos

..........................................................

© 2017   Creado por AMPc.   Tecnología de

Emblemas  |  Reportar un problema  |  Política de privacidad  |  Términos de servicio